Deprecated: idn_to_ascii(): INTL_IDNA_VARIANT_2003 is deprecated in /var/www/blogotext/inc/boot.php on line 200
Installer un paquet depuis un dépôt Snapshot - Pansebete

Pansebete

Une note autocollante repositionnable sur une tête de bois

Installer un paquet depuis un dépôt Snapshot

22/06/2013 ⋅ Aucun commentaire

Par bendia

On a parfois besoin d'installer la version d'un paquet qui n'est plus présente dans les dépôts. On peut alors utiliser une image des dépôts prises à un moment précis : un snapshot.

Ou trouver les dépôts snapshot


La page d'accueil du dépôt se trouve à cette adresse : http://snapshot.debian.org/
Imaginons vouloir installer un paquet en version 1.2-3. On sait que cette version est dans les dépôts main de sid le 07 janvier 2013. Naviguons donc vers la page debian, choisissons 2013 puis 01.
Nous tombons sur une liste de toutes les images du dépôt prises dans le mois de janvier 2013

Snapshot thubnail

Il nous suffit de choisir une archive du 07 janvier 2013, au hasard, la première. Elle est crée à 03h36min53s. Cela nous permet de déterminer l'adresse de l'archive:

http://snapshot.debian.org/archive/debian/20130107T033653Z

Construire une entrée pour /etc/apt/sources.list


Reste à construire une entrée pour notre sources.list.

Simple, il suffit de prendre cette adresse et de mettre les mêmes éléments autour que pour un dépôt classique

deb http://snapshot.debian.org/archive/debian/20130107T033653Z/sid main

Installer un paquet en provenance de cette archive


Simple, me direz vous ! Il suffit maintenant de faire

apt-get update
apt-get install paquet=1.2-3

Si l'archive est quelque peu ancienne, voilà le résultat probable

E: Release file for http://snapshot.debian.org/archive/debian/20130107T033653Z/dists/sid/Release is expire (invalid since mon grand père portait des culottes courtes) Update for this repository will not be applied.
Unable to locate package paquet

Et oui, seule solution : signifier à apt qu'il ne doit pas se soucier de l'âge de mon grand-père du dépôt :

apt-get -o 'Acquire::Check-Valid-Until=false' update
apt-get install paquet=1.2-3

et là, miracle, votre paquet va s'installer !

Aucun commentaire